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本文介绍通过远程桌面连接Windows实例,提示“远程桌面由于以下原因之一无法连接到远程计算机:未启用对服务器的远程访问、远程计算机已关闭、远程计算机在网络上不可用”错误的解决方案。

问题描述

使用远程桌面连接Windows实例时,提示“远程桌面由于以下原因之一无法连接到远程计算机:未启用对服务器的远程访问、远程计算机已关闭、远程计算机在网络上不可用”错误,具体报错信息如下图所示。

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问题原因

出现该问题可能有以下原因:

  • 实例网络连接中断。您可以参考步骤五:检查防火墙配置和步骤八:检查网络修复该问题。

  • 远程连接指定的端口和实例监听的端口不一致。您可以参考为什么使用默认的端口(3389)无法登录Windows实例?修复该问题。

  • RDP-Tcp会话未处于监听状态。您可以参考解决方案修复该问题。

    说明

    您可以使用query sessionqwinsta命令,查看RDP-Tcp会话的监听状态。

    作为对照,正常实例使用qwinsta命令的返回结果如下图所示,可供参考。

    image

解决方案

为解决因RDP-Tcp会话未处于监听状态而导致远程桌面连接失败的问题,您需要将异常实例中的RDP-TCP注册表项替换为来自正常工作实例的相应注册表项。

  1. 导出正常实例中的RDP-TCP注册表。

    1. 远程连接到一台具有正常远程桌面连接(RDP)功能的Windows实例,确保版本与异常实例相同。

      具体操作,请参见通过密码或密钥认证登录Windows实例。

    2. Win键 + R打开运行对话框,输入regedit,然后单击确定

    3. 在弹出的注册表编辑器对话框中,右键单击HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlTerminal ServerWinStationsRDP-Tcp注册表,然后选择导出

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    4. 在弹出的导出注册表文件对话框中,文件名填写为rdp-tcp.reg,然后单击保存

  2. 将已保存的rdp-tcp.reg文件上传至异常实例中。

    说明

    请您根据实际业务情况选择合适的文件上传方法。常见的文件传输方式包括但不限于以下几点:

    • 通过可信的文件中转服务下载。

    • 使用阿里云对象存储服务(OSS)。更多信息,请参见什么是对象存储OSS。

  3. 替换异常实例中的RDP-TCP注册表。

    1. 通过VNC连接异常Windows实例。

      具体操作,请参见使用VNC登录实例。

    2. 按照上述步骤将异常实例中的RDP-TCP注册表导出至名为rdp-tcp.bak.reg的文件中。

    3. 右键单击HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlTerminal ServerWinStationsRDP-Tcp注册表,然后选择删除

    4. 注册表编辑器对话框中,选择文件 > 导入,将由正常实例中导出的离线注册表文件rdp-tcp.reg拷贝到异常实例中。

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  4. 执行以下任一命令,重启远程桌面连接服务,以使配置生效。

    • PowerShell命令

       

      Start-Service TermService -Force
    • 命令行

       

      sc start TermService
  5. 重新使用远程桌面连接Windows实例,确保可以正常连接。




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